แกน Z เจ้าปัญหากะ KCAM

ทำงานบนวินโดวส์

แกน Z เจ้าปัญหากะ KCAM

Postโดย ชายวี วันที่ 09 พ.ค. 2008, 19:39

ที่ผมไม่ใช้ KCAM ในการกัดงานนั้นเพราะว่าเคยใช้แล้วปรากฎว่าแกน Z เพี้ยน ลงลึกกว่าที่ควรจะเป็นจนกระแทกโต๊ะทำให้ดอกหักไป 3 ดอก ก็เลยเข็ดไม่ใช้อีกเลย และไม่สามารถหาเหตุผลได้ด้วย เพราะว่าแกน X กะ Y ไม่มีปัญหาใดๆ ทั้งสิ้น แต่พอ mdi ให้วิ่งไปทั่วโต๊ะและระดับ z ที่ต่างกัน พอกลับมาที่เดิม Z ลงลึกกว่าที่ควรจะเป็นทุกทีก็เลยเลิกใช้ไปปริยาย ยอมกลับไปใช้ pc_cnc เหมือนเดิม

จนมาเมื่อวันมะรืนคุณ ALnaluk มาเยี่ยมที่บ้านและก็มีการแลกเปลี่ยนความรู้กัน ซึ่งบังเอิญใช้เครื่องเหมือนกันด้วยก็เจอปัญหาเดียวกัน เขาบอกว่าสามารถแก้ไขได้โดยกำหนดความเร็วแกน Z ให้ต่ำเข้าไว้ ก็เลยมาบอกไว้ให้ทราบกันสำหรับท่านที่เจอปัญหานี้

ชายวี
Professional
 
ข้อความ: 2285
เป็นสมาชิกตั้งแต่: 22 มี.ค. 2008, 13:25
ภูมิลำเนา: เชียงใหม่ เจ้า........

Re: แกน Z เจ้าปัญหากะ KCAM

Postโดย tana วันที่ 03 ธ.ค. 2008, 23:27

ถามผู้รู้ว่า ทำไม save Toolpaths จากArtCAMPro2008 เป็น Apex-(*cnc) แล้วกัดงานด้วยkcamจะผิดพลาดตลอด
จากที่ผมทดลอง save Toolpaths จากArtCAMPro2008 เป็น G-code-(*tap)โดยไม่ต้องแก้ไขFile postp ของ
ArtCAM เลย แกนzก็ปกติดี ทุกอย่างดี เลยไม่รู้จะถูกต้องหรือเปล่า เพราะส่วนมากจะบอกให้ save เป็นApex-(*cnc)
tana
 
ข้อความ: 4
เป็นสมาชิกตั้งแต่: 07 ก.ค. 2008, 22:02

Re: แกน Z เจ้าปัญหากะ KCAM

Postโดย ชายวี วันที่ 04 ธ.ค. 2008, 07:30

เปิด g-code ที่ได้เทียบกันดูครับ

ชายวี
Professional
 
ข้อความ: 2285
เป็นสมาชิกตั้งแต่: 22 มี.ค. 2008, 13:25
ภูมิลำเนา: เชียงใหม่ เจ้า........

Re: แกน Z เจ้าปัญหากะ KCAM

Postโดย kop10 วันที่ 17 ก.พ. 2010, 11:33

ขอถามหน่อยครับ..คือผมลงคอมพิวเตอร์ เครื่องใหม่ ..เพื่อใช้คุม เครื่อง CNC (คอมตัวใหม่จะแรงกว่าตัวเดิม) แล้วก็ลงโปรแกรม KCAM ลอง SET ค่า Table Setup แล้ว ลองปรับ แกน Z มันไม่ลงครับ มันฝืด มาก ๆ ผม Set ค่าไว้ดังนี้ครับ...(มีรูปประกอบ) ไม่ทราบว่าต้อง Set ค่ายังไง บ้างครับ.. ถึงเครื่องจะเดินได้ปกติ ถ้าผมลด ค่า Axis ลง เหลือซัก 2 มันก็ เดินได้ครับ แต่ช้า .. ช้ากว่า คอมเครื่องเดิมอีกครับ .. ทัี้้ง ๆ ที่คอม ตัวเดิม ความเร็ว สู้ตัวนี้ไม่ได้ เลย .. ออ .. คอม ตัวนี้ความเร็วอยู่ที่ CPC 3 G intel Ram 512 ครับ ผม ...
คุณไม่มีสิทธิ์ดูไฟล์ที่แนบในข้อความนี้
kop10
Basic
 
ข้อความ: 10
เป็นสมาชิกตั้งแต่: 03 ก.ย. 2009, 15:45

Re: แกน Z เจ้าปัญหากะ KCAM

Postโดย nookhook วันที่ 17 ก.พ. 2010, 12:51

ไม่เคยใช้เลยครับ kcam นี่ รอท่านอื่นมาช่วยตอบ
แต่สงสัยว่าชอบใช้ระบบนิ้วหรือครับ :62

nookhook
Master
 
ข้อความ: 512
เป็นสมาชิกตั้งแต่: 24 ก.ย. 2008, 20:53

Re: แกน Z เจ้าปัญหากะ KCAM

Postโดย kop10 วันที่ 17 ก.พ. 2010, 15:09

kop10 เขียนโดย:ขอถามหน่อยครับ..คือผมลงคอมพิวเตอร์ เครื่องใหม่ ..เพื่อใช้คุม เครื่อง CNC (คอมตัวใหม่จะแรงกว่าตัวเดิม) แล้วก็ลงโปรแกรม KCAM ลอง SET ค่า Table Setup แล้ว ลองปรับ แกน Z มันไม่ลงครับ มันฝืด มาก ๆ ผม Set ค่าไว้ดังนี้ครับ...(มีรูปประกอบ) ไม่ทราบว่าต้อง Set ค่ายังไง บ้างครับ.. ถึงเครื่องจะเดินได้ปกติ ถ้าผมลด ค่า Feedrate ลง เหลือซัก 2 มันก็ เดินได้ครับ แต่ช้า .. ช้ากว่า คอมเครื่องเดิมอีกครับ .. ทัี้้ง ๆ ที่คอม ตัวเดิม ความเร็ว สู้ตัวนี้ไม่ได้ เลย .. ออ .. คอม ตัวนี้ความเร็วอยู่ที่ CPC 3 G intel Ram 512 ครับ ผม ...
kop10
Basic
 
ข้อความ: 10
เป็นสมาชิกตั้งแต่: 03 ก.ย. 2009, 15:45

Re: แกน Z เจ้าปัญหากะ KCAM

Postโดย ชายวี วันที่ 17 ก.พ. 2010, 19:10

ปรับค่า Feed Rate ทั้งสามตัว

ชายวี
Professional
 
ข้อความ: 2285
เป็นสมาชิกตั้งแต่: 22 มี.ค. 2008, 13:25
ภูมิลำเนา: เชียงใหม่ เจ้า........

Re: แกน Z เจ้าปัญหากะ KCAM

Postโดย suwatpb วันที่ 28 ก.ย. 2012, 16:50

ในเวอชั่น4 ณ เวลาที่โพสนี้ พบปัญหาอย่างหนึ่งคือ เมื่อสั่งแกนzขึ้นหรือลงก็แล้วแต่ และมันได้เลื่อนไปถึงตำแหน่งแล้ว
ในบางครั้งโปรแกรมไม่ส่งสัญญาณ step ออกมารักษาค่าตำแหน่งไว้ กลายเป็นไฟลบเฉยเลย อันนี้จะทำให้หัวตกได้
แต่มันเป็นบ้าง ไม่เป็นบ้าง ... ปิดแล้วเปิดโปรแกรมใหม่หาย หรือถ้าปิดเครื่องแล้วเปิดเครื่องใหม่จะชัวร์กว่าครับ พอร์ทได้รีเซ็ทใหม่ด้วย
(ไม่ใช่รีสตาร์ทในเมนูสตาร์ทของวินโดว์นะครับ เลือก Turn off เลย.. คือ ปิดสวิตซ์จ่ายไฟเข้าคอมหรือชักปลั๊กไฟด้วย แล้วทิ้งไปอึดใจใหญ่ๆค่อยเปิดใหม่)

เฝ้าดูอาการได้ที่เมนู View - Parallel port I/O display ดูสถานะไฟที่ขาที่คุณกำหนดค่า step / Direction ของแกน XYZ นั่นแหล่ะครับ
หรือถ้าเอามันส์สนุกเห็นจะๆคาตา ติดไว้กับโต๊ะตัดงานก็ได้ ก็ต่อหลอด LED 8 ดวง แล้วดูมันกระพริบและิติดค้างในแกนที่เกี่ยวข้องครับ
ผมสอนวิธีทำไว้แล้ว ดูที่

http://www.facebook.com/FunCNC/photos

suwatpb
Master
 
ข้อความ: 432
เป็นสมาชิกตั้งแต่: 30 มิ.ย. 2009, 10:14
ภูมิลำเนา: http://www.funcnc.com/

Re: แกน Z เจ้าปัญหากะ KCAM

Postโดย suwatpb วันที่ 29 ก.ย. 2012, 08:19


suwatpb
Master
 
ข้อความ: 432
เป็นสมาชิกตั้งแต่: 30 มิ.ย. 2009, 10:14
ภูมิลำเนา: http://www.funcnc.com/


ย้อนกลับไปยัง KCAM

ใครออนไลน์บ้างเอ่ย

สมาชิก 0 ท่าน และ ผู้เยี่ยมชมอีก 1 ท่าน กำลังเยี่ยมชมกระดานนี้อยู่